如何配置操作系统以排除Kaspersky Security Center网络代理远程安装故障
上次更新时间: 2024年8月7日
ID: 16026
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显示本文涉及的应用程序和版本
- Kaspersky Security Center14.2(版本 14.2.0.26967)
- Kaspersky Security Center14(版本 14.0.0.10902)
- Kaspersky Security Center 13.2 (版本 13.2.0.1511)
- Kaspersky Security Center 13.1 (版本 13.1.0.8324)
- Kaspersky Security Center 13 (版本 13.0.0.11247)
本文提供了运行 Microsoft Windows Vista – Windows Server 2008 操作系统(以下简称 OS)及更高版本的设备的配置示例。更改操作系统参数时请严格遵守内部信息安全政策的要求。
这些说明不直接适用于卡巴斯基应用程序。如果您的操作系统没有损坏并且运行正常,我们的工程师可以帮助您配置文章中描述的参数。在所有其他情况下,请联系 Microsoft 支持。
这些说明不直接适用于卡巴斯基应用程序。如果您的操作系统没有损坏并且运行正常,我们的工程师可以帮助您配置文章中描述的参数。在所有其他情况下,请联系 Microsoft 支持。
问题
尝试通过管理服务器使用操作系统资源或通过分发点使用操作系统资源执行网络代理或带有第三方软件的用户包的远程安装任务时,由于目标设备的操作系统配置不正确,可能会出现错误。
原因
错误 | 原因 |
---|---|
以下帐户无法使用共享文件夹“\\192.0.2.45\admin$”:<Current Administration Server service account> (拒绝访问)”。 | 远程用户帐户控制 (UAC) 已启用。 |
“分发点“˂DP_name˃”无法启动远程安装。从管理服务器下载安装包到设备上的共享文件夹时返回错误:“Kaspersky Security Center14.2 网络代理服务帐户”(拒绝访问。)未找到更多分发点。” | |
“共享文件夹“\\192.0.2.45\admin$”无法供以下帐户使用:获取文件系统对象“\\192.0.2.45\admin$\Temp\KAV Remote Installations\17448b048259422d801bb86c01520348_1”的访问权限时发生错误 1181/0x43(“系统错误 0x43(找不到网络名称。)”)。 | 没有共享的管理文件夹。 |
“分发点“˂DP_name˃”无法启动远程安装。从管理服务器下载到设备上的共享文件夹的安装包返回错误:获取文件系统对象“\\192.0.2.45\admin$\Temp\KAV Remote Installations\12ea84896a6b4b679dfdaeb663cedd00_1”的访问权限时发生错误 1181/0x43(“系统错误 0x43(找不到网络名称。)”)。未找到更多分发点。” | |
以下帐户无法使用共享文件夹“\\192.0.2.45\admin$”:<Current Administration Server service account> (RPC服务器不可用)”。 |
|
“分发点“˂DP_name˃”无法启动远程安装。从管理服务器下载安装包到设备上的共享文件夹时返回错误:“Kaspersky Security Center14.2 网络代理服务帐户”(RPC 服务器不可用。)未找到更多分发点。” | |
“该设备可能已与网络断开连接。” | 文件和打印机共享已禁用。 |
“RPC 服务器不可用。” | 操作系统的正常运行已被破坏。 |
解决办法
已启用远程用户帐户控制
如果目标设备属于工作组且不在 Active Directory 域中,请禁用其上的远程 UAC。
禁用远程 UAC 不会影响本地 UAC。
- 以管理员身份打开命令行。
- 运行命令禁用远程 UAC:
REG ADD HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\System /v LocalAccountTokenFilterPolicy /t REG_DWORD /d 1 /f
- 重新启动目标设备上的操作系统。
有关 UAC 的详细信息,请参见 Microsoft 网站:
没有共享管理文件夹
要使用 Windows 工具执行远程安装任务,必须有共享管理文件夹 ADMIN$、C$ 和 IPC$。有时可以禁用它们以提高操作系统的安全性。
- 以管理员身份打开命令行。
- 使用以下命令检查 ADMIN$、C$ 和 IPC$ 文件夹是否存在:
净份额
- 如果有必要,恢复共享的管理文件夹。
- 以管理员身份打开命令行。
- 运行以下命令:
REG ADD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters /v AutoShareServer /t REG_DWORD /d 1 /fREG ADD HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters /v AutoShareWks /t REG_DWORD /d 1 /f - 重新启动目标设备上的操作系统并再次检查管理文件夹是否存在。
有关缺少管理共享时可能出现的问题的详情,请参阅Microsoft 网站。
LanmanServer、RPC、DCOM 服务状态不正确
LanmanServer、RPC 和 DCOM OS 服务提供远程应用程序安装。LanmanServer、RPC 和 DCOM 服务必须处于正在运行状态才能运行远程应用程序安装任务。
检查状态:
- 以管理员身份打开命令行。
- 运行命令:
powershell “获取服务 LanmanServer、RpcSs、RpcEptMapper、DcomLaunch”
如果状态不同,请在域组策略中或通过本地服务管理单元 (services.msc) 配置服务启动设置。
文件和打印机共享已禁用
文件和打印机共享可以将安装包复制到目标设备。要启用文件和打印机共享:
- 按在键盘上按 +R,输入ncpa.cpl并单击确定。
- 在受影响的设备上,本地打开连接到管理服务器或分发点的网络适配器的上下文菜单,然后选择“属性” 。
- 选中文件和打印机共享复选框并单击确定。
- 关闭网络适配器并重新打开或重新启动设备操作系统以应用更改。
操作系统的正常运行已被中断
如果远程安装的问题并非发生在网络上的所有设备上,请在这些设备上检查问题的根本原因并遵循以下建议。
- 磁盘的系统分区上没有可用空间。
在这种情况下,操作系统服务停止正常工作。释放磁盘空间并重新启动设备。 - 从 Windows 更新中心安装更新后,操作系统正在等待重新启动。
如果安装未完成,远程安装任务可能会中断。要解决该问题,请重新启动设备。 - OS已运行较长时间且未重新启动。
如果您几个月没有重新启动操作系统,请重新启动它。 - WMI 存储库已损坏。
检查其完整性并使用Microsoft 网站上的说明进行故障排除。 - 操作系统文件已损坏。
检查并恢复OS系统文件的完整性。请参阅Microsoft 网站上的说明以正确运行以下命令。然后重新启动设备。
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth
证监会/扫描
如果问题仍然存在该怎么办
- 使用其他建议来解决网络可用性问题。
- 如果安装任务成功完成并出现消息“远程安装已在此设备上成功完成。”,但网络代理不可用或未出现在设备对象上,请参阅文章中的建议。
- 如果深度数据包检测 (DPI) 或解密和流量分析技术 (SSL 检查) 被用作第三方保护软件的一部分,则尝试排除检查目标设备与管理服务器的连接。
- 使用额外的集中工具来部署网络代理:
- 使用Active Directory 组策略
- 集成到参考操作系统安装映像中
- 用于集中应用程序部署的第三方工具
如果问题仍然存在,请通过卡巴斯基公司账户向卡巴斯基技术支持提交请求。在您的请求中:
- 描述问题:附上安装错误的屏幕截图,指定您执行了说明中的哪些步骤,并提供本文中诊断命令的输出。
- 收集诊断信息并将创建的文件附加到您的请求中。