安装或删除Kaspersky Security Center网络代理时出现的问题
上次更新时间: 2024年8月8日
ID: 16032
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显示本文涉及的应用程序和版本
- Kaspersky Security Center14.2(版本 14.2.0.26967)
- Kaspersky Security Center14(版本 14.0.0.10902)
- Kaspersky Security Center 13.2 (版本 13.2.0.1511)
- Kaspersky Security Center 13.1 (版本 13.1.0.8324)
- Kaspersky Security Center 13 (版本 13.0.0.11247)
请不要将本文中的建议用于管理服务器。这些说明仅适用于在安装或删除网络代理时遇到问题的托管设备。
问题
安装网络代理时,可能会出现系统错误:
- “错误 25003。系统错误 0x1F(连接到系统的设备无法运行。)”。
- “错误(系统错误 0x80090006(无效签名。))”。
- “(1192/0x0(“系统容器‘LOC-PUB-6EEB50F8D2EB46029DB4CCB77E0DA651’已损坏”)”。
安装Kaspersky Security Center网络代理或删除应用程序可能会导致其他错误。但是,使用清理实用程序删除以前安装的网络代理版本并不能修复错误。
原因
- 设备操作系统的受保护存储已损坏。这会影响网络代理安装向导。
- 安装的网络代理版本与设备的操作系统不兼容。
- 应用程序以前安装时残留的文件和记录会阻止其安装或删除。
解决办法
如果问题与设备上损坏的 Windows 保护存储有关,请使用说明进行恢复。
- 检查网络代理是否支持您的操作系统。
- 如果问题是由以前安装的文件或记录引起的,请收集诊断信息并向技术支持提交请求。
如何恢复受保护的存储
- 以管理员身份打开命令行并运行此命令以在受保护存储文件夹中搜索网络代理密钥:
- 重新启动设备并安装网络代理。
如果问题仍然存在:- 使用以下命令恢复Windows 映像:
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth
证监会/扫描 - 重新启动设备并重新安装网络代理。
- 使用以下命令恢复Windows 映像:
powershell“Get-ChildItem“$env:ProgramData\Microsoft\Crypto\RSA\MachineKeys”| 选择字符串“6eeb50f8d2eb46029db4ccb77e0da651”| 选择对象路径 | FL”
如果检测到网络代理密钥,请从存储文件夹中手动删除它们:%ProgramData%\Microsoft\Crypto\RSA\MachineKeys
以“f686aace6942fb7f7ceb<...>”开头的文件读取错误是所有操作系统的正常现象。此密钥文件由远程桌面服务使用。如果存在其他读取错误,请使用Microsoft 网站上的说明恢复 MachineKeys 文件夹的正确权限。
如果系统错误仍然存在,请重新安装 Windows 操作系统或联系Microsoft 技术支持。
如果问题仍然存在该怎么办
通过卡巴斯基公司账户向技术支持提交请求。
请详细描述问题并附上:
- 错误的截图。
- GetSystemInfo 报告未连接到网络代理的目标设备的操作系统事件。
- 网络代理的安装日志 。
- 导出的注册表分支(参见说明):
HKEY_LOCAL_MACHINE\SOFTWARE\Classes\安装程序\
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\
HKEY_CLASSES_ROOT\安装程序\产品\
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\
HKEY_CLASSES_ROOT\安装程序\产品\