Kaspersky Security Center的许可证到期日期不正确
上次更新时间: 2024年8月8日
ID: 16001
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显示本文涉及的应用程序和版本
- Kaspersky Security Center14.2(版本 14.2.0.26967)
- Kaspersky Security Center14(版本 14.0.0.10902)
- Kaspersky Security Center 13.2 (版本 13.2.0.1511)
问题
使用激活码向Kaspersky Security Center添加许可证后,许可证到期日期和许可证激活日期更改为 1970 年。因此,许可证无法在受管设备上激活。添加密钥任务需要很长时间来处理,并且会失败并显示错误消息:“无法转换服务器地址。请检查互联网连接设置。”
原因
连接到卡巴斯基激活服务器时您可能会遇到此问题。当您使用激活码激活应用程序时,需要访问激活服务器来重新验证许可证。
解决办法
根据您的情况遵循以下建议:
- 管理服务器用于向设备分发许可证。
- 网络与互联网隔离或之前的建议没有帮助。
- 激活问题仅发生在某些设备上。
如果您使用管理服务器将许可证分发给设备
- 确保连接管理服务器和外部服务的网络设置正确。您可以在提供 Internet 访问的代理服务器或网络设备的日志中检查这一点。
- 检查 SSL 端口是否允许使用未加密的网络流量。
- 如果您的基础设施使用深度数据包检测 (DPI) 或流量解密和分析技术 (SSL 检查) 作为第三方安全解决方案的一部分,请确保管理服务器和代理服务器之间的加密连接扫描已被禁用。
如果启用了加密连接扫描,更新下载将失败,并出现错误“无法建立 HTTPS 连接:TLS 错误 (54)。'/'”。要解决此问题,请将 HTTPS 替换为 HTTP ,以避免代理服务器出现问题。 - 如果管理服务器通过代理服务器下载更新,请检查代理服务器的凭据是否正确。
要检查这一点,请使用这些凭据登录到代理服务器进行检查。 - 按照这些说明尝试将激活码重新添加到管理服务器存储库时,检查是否存在网络连接错误。
- 使用这些说明检查Kaspersky Security Center是否用作代理服务器来激活托管设备上的应用程序。
- 使用这些说明检查管理服务器属性中配置的应用程序激活网络端口是否可以在受管设备上访问。
- 确保Kaspersky Security Center和端点设备保护应用程序的版本受支持。我们建议将应用程序升级到最新版本。
- 确保受管设备上的网络代理版本与管理服务器版本相匹配。
如果实施了所有建议,则在下次与管理服务器同步后将成功完成激活,并且日期将被更正。网络代理的默认同步周期为 15 分钟,但我们建议等待 30 分钟,并检查所有活动设备上的问题是否已解决。有关同步设置的更多信息,请参阅本文。
如果网络与互联网隔离
如果某些设备出现激活问题
如何检查用于激活的网络端口是否可访问
- 打开 KSC,选择管理服务器节点并单击服务器属性。
- 转到管理服务器连接设置→附加端口。
- 检查激活代理服务器字段的 SSL 端口中指定的端口是什么。
- 检查在移动设备激活端口字段中指定的端口是什么。
- 使用以下命令检查上一步中描述的端口的连接:
powershell 测试NetConnection ksc.example.com -端口 17000
ksc.example.com 是管理服务器的完全限定域名 (FQDN) 17000 是用于在受管设备上激活应用程序的端口
- 检查命令执行结果,并按照下表“解决方案”列中描述的指南进行操作。
错误/结果 | 原因 | 解决办法 |
---|---|---|
出现错误“˂ksc_name˃ 的名称解析失败”;字符串“RemoteAddress”为空。 | FQDN 名称无法转换为 IP 地址。 | 尝试使用 IP 地址连接到 KSC 管理服务器。 为了能够通过 FQDN 名称连接,请修复 DNS 名称解析问题。 |
“TCP 连接(˂ksc_ip˃:˂activation_port˃)失败。” | 该问题与网络可用性有关。 | 检查网络设备中的流量过滤设置、操作系统防火墙以及终端节点的保护解决方案。确保启用允许规则来建立连接。 |
“Ping 至 ˂ksc_ip˃ 失败,状态为:超时” | 管理服务器没有对回显请求做出响应。 在某些情况下,这种行为是正常的,并不表示管理服务器存在网络可用性问题。如果是,则在输出命令的时候,会有“PingSucceeded:True”字符串确认Echo Response。 | 如果无法暂时启用 ICMP 协议通过 Echo 请求进行诊断:
|
出现字符串“TcpTestSucceeded: True”。 | 可以从管理员的工作站访问 MMC 端口。 | 通过远程管理控制台再次检查连接。 |
如何检查Kaspersky Security Center是否被用作代理服务器来激活托管设备上的应用程序
- 打开Kaspersky Security Center并转到策略。
- 右键单击所需应用程序的策略(例如Kaspersky Endpoint Security for Windows),然后单击“属性” 。
- 选择常规设置→应用程序设置。
- 确保在操作模式块中设置了挂锁,并且选中了使用Kaspersky Security Center作为激活的代理服务器复选框。可用的策略设置集根据托管应用程序而有所不同。使用Kaspersky Security Center作为激活的代理服务器选项适用于所有应用程序,但可能位于另一组设置中。