Kaspersky Security Center
 
 

解决 Windows 网络代理和管理服务器之间的连接问题

上次更新时间: 2024年8月7日 ID: 12776
 
 
 
 

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显示本文涉及的应用程序和版本
  • Kaspersky Security Center14.2(版本 14.2.0.26967)
  • Kaspersky Security Center14(版本 14.0.0.10902)
 
 
 
 

问题

  • 网络代理已成功远程安装,但目标受管设备对象未出现在管理服务器上。或者出现了该物体,但是没有任何标记表明其上安装了网络代理。
  • 网络代理与应用程序包的同时远程安装以 50% 的速度运行,并在代理已成功安装的消息出现后停止。控制台界面的事件日志显示该应用程序尚未安装。
  • 在旧版本上安装新版本的网络代理后,与受管设备的连接将丢失。任务会显示一条消息,提示您重新启动受管设备。
  • 使用klnagchk.exe实用程序检查网络代理与管理服务器的连接最终出现错误。
  • 网络代理的远程安装在出现事件“正在运行(32%)(设备无法访问)”或“安装服务正在此设备上运行”时停止。请稍等...”。
    目标设备上的网络代理服务未运行,当您尝试启动任何组件时:
    • Windows 应用程序日志中出现有关emcat.dlem.dll文件的事件:“信息 1603。文件 C:\Program Files (x86)\ 卡巴斯基 Lab\NetworkAgent\em.dll 正在使用中。关闭该应用程序并重试。”
    • 网络代理崩溃,出现错误“错误应用程序名称:klnagent.exe,版本:14.2.0.26967,时间戳:0xa0f42d48 错误模块名称:KERNELBASE.dll,版本:6.1.7601.17514,时间戳:0x4ce7bafa <...>”。

原因

  • 网络代理包或策略设置不正确。
  • 网络代理服务(klnagent)失败。
  • 第三方软件阻止网络代理文件。
  • 网络代理和管理服务器之间没有连接。

解决办法

重新启动目标设备的操作系统并确保光盘上有足够的空间。如果问题仍然存在,还有几种解决方案。

 
 
 
 

解决方案 1。搜索未分配的设备

 
 
 
 

解决方案 2。检查任务分发的网络代理包中的连接设置

 
 
 
 

解决方案 3。在操作系统过时的设​​备上检查 KB3063858 更新

 
 
 
 

解决方案 4。检查网络代理服务是否启动以及其文件是否被阻止

 
 
 
 

解决方案 5。检查网络代理是否已安装

 
 
 
 

解决方案 6。检查目标设备是否可以访问管理服务器

 
 
 
 

如果问题仍然存在该怎么办

 
 
 
 
 
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