Kaspersky Security Center备份期间出错
为方便您阅读,本文已使用第三方提供的机器翻译软件进行翻译,并按“原样”发布。对于这些从英语翻译而来的内容的准确性、可靠性或完整性,我们不做任何明示或暗示的保证。由于翻译软件的限制,某些内容的翻译可能不准确。如需查看英语版本,请点击此处。
显示本文涉及的应用程序和版本
- Kaspersky Security Center14.2(版本 14.2.0.26967)
- Kaspersky Security Center14(版本 14.0.0.10902)
- Kaspersky Security Center 13.2 (版本 13.2.0.1511)
在Kaspersky Security Center备份数据时,可能会出现错误。最常见的原因有:
- 操作系统或硬件资源故障;
- 缺乏执行备份所需的权限;
- klbackup 工具故障;
- 数据库已损坏或配置文件与数据库的状态不匹配。
您可以在下面找到有关这些错误和解决方案的详细信息,但首先检查是否满足以下条件:
- 您的设备符合Kaspersky Security Center硬件和系统要求。
- SQL服务器平台已更新至最新版本。
- 已安装最新的 SQL 服务器补丁。
创建备份副本时出错
创建备份副本时,出现错误消息“文件夹路径无效。出现错误 1181/0x52e,因为管理服务器没有写入权限...”。
解决办法
- 检查运行管理服务器和 SQL Server 服务的用户帐户是否有权限访问共享文件夹并向其中写入数据。
- 检查共享文件夹是否存在并且可以从管理服务器和 SQL Server 访问。
- 配置将执行备份的文件夹的访问权限。
klbackup工具或备份任务错误
klbackup 工具或备份任务可能会在 klbackup.log 文件中显示以下错误:“正在备份数据库...失败 - 检查 SQL Server 是否有足够的权限访问备份路径...无法打开备份设备...操作系统错误 3(未发现错误)。”。
解决办法
- 如果 SQL Server 和管理服务器位于不同的计算机上,请使用 UNC 路径指向备份文件夹。这是必要的,以便klbackup工具和 SQL Server 可以同时访问备份文件夹。有关 UNC 路径的详细信息,请参阅Microsoft 支持站点。
- 配置将执行备份的文件夹的访问权限。SQL Server 只能在其可以直接访问的文件夹中创建或恢复备份(此要求与 MySQL 无关)。该文件夹必须具有读写权限共享(必须为共享和 NTFS 配置 ACL)。
如果问题仍然存在,请按照以下说明操作。
备份任务以错误结束
klbackup.log 文件中的备份任务可能会以以下错误结束:“正在备份数据库...失败 - 检查 SQL Server 是否有足够的权限访问备份路径...无法打开备份设备...操作系统错误 3(未发现错误)。”。
解决办法
klbackup 工具失败并出现错误
klbackup 工具可能会失败并出现以下错误:“正在备份数据库...失败 - 检查 SQL Server 是否有足够的权限访问备份路径...无法打开备份设备...操作系统错误 3(未发现错误)。”。
解决办法
备份任务期间出现一般数据库错误
备份任务可能会以以下错误结束:“通用 DB 错误:“8985‘无法在 sys.database_files 中定位数据库‘KSCSDB’的文件‘DATABASE_LOG’。该文件不存在或已被删除。{42000};'LastStatement='DBCC SHRINKFILE (DATABASE_LOG);''。
原因
发生该错误的原因是物理和逻辑数据库文件名不匹配。如果您自行创建了Kaspersky Security Center服务器数据库并更改了逻辑文件名,则可能会发生这种情况。
解决办法
更改逻辑数据库文件名,使其与物理名称匹配。
备份任务期间出现“数据库已损坏”错误
备份任务可能以以下错误结束:“数据库已损坏。至少一个存储库 C:\ProgramData\Application Data\KasperskyLab\adminkit\1093\gsyn\klsdata.dat 已损坏,且无法恢复。需要修复硬件并重新安装应用程序。”